keyutils 1.6.3-2

This commit is contained in:
xhaa123 2024-11-04 18:24:39 +08:00
parent 1854f06274
commit 373bdba77d
3 changed files with 64 additions and 7 deletions

View File

@ -6,22 +6,34 @@
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=keyutils
pkgver=1.6.3
pkgrel=1
pkgrel=2
pkgdesc="Linux Key Management Utilities"
arch=('x86_64')
url="https://www.kernel.org"
license=('GPL2' 'LGPL2.1')
depends=('glibc' 'bash')
backup=(etc/request-key.conf)
source=(https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/${pkgname}.git/snapshot/${pkgname}-${pkgver}.tar.gz)
sha256sums=(a61d5706136ae4c05bd48f86186bcfdbd88dd8bd5107e3e195c924cfc1b39bb4)
source=(https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/${pkgname}.git/snapshot/${pkgname}-${pkgver}.tar.gz
request-key.conf.patch
reproducible.patch)
sha256sums=(a61d5706136ae4c05bd48f86186bcfdbd88dd8bd5107e3e195c924cfc1b39bb4
539b163178fea41d645ae01bd1c74d9c6f6a92f3094df7cb3ed487a0f7f8b15b
7bb7400b2b8c8f0288c86ec9191f8964a1e682745a204013d5fc7c2e1a253d8e)
prepare() {
cd ${pkgname}-${pkgver}
# fix paths of binaries in /etc/request-key.conf
patch -Np0 -i ${srcdir}/request-key.conf.patch
# make keyutils reproducible
patch -Np1 -i ${srcdir}/reproducible.patch
}
build() {
cd ${pkgname}-${pkgver}
make
make CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LIBDIR=/usr/lib64 SBINDIR=/usr/sbin BINDIR=/usr/bin
}
package() {

24
reproducible.patch Normal file
View File

@ -0,0 +1,24 @@
Adhere to the SOURCE_DATE_EPOCH standard and use it's date when set
otherwise fall back to the default behaviour.
Signed-off-by: Jelle van der Waa <jelle@vdwaa.nl>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 33a451e..9066d5d 100644
--- a/Makefile
+++ b/Makefile
@@ -108,7 +108,7 @@ all: keyctl request-key key.dns_resolver
###############################################################################
#RPATH = -Wl,-rpath,$(LIBDIR)
-VCPPFLAGS := -DPKGBUILD="\"$(shell date -u +%F)\""
+VCPPFLAGS := -DPKGBUILD="\"$(date --utc --date="@${SOURCE_DATE_EPOCH:-$(date +%s)}" +%F)\""
VCPPFLAGS += -DPKGVERSION="\"keyutils-$(VERSION)\""
VCPPFLAGS += -DAPIVERSION="\"libkeyutils-$(APIVERSION)\""
--
2.21.0

21
request-key.conf.patch Normal file
View File

@ -0,0 +1,21 @@
--- request-key.conf.old 2013-05-28 15:34:10.966001242 +0200
+++ request-key.conf 2013-05-28 15:35:34.857969598 +0200
@@ -31,11 +31,11 @@
#OP TYPE DESCRIPTION CALLOUT INFO PROGRAM ARG1 ARG2 ARG3 ...
#====== ======= =============== =============== ===============================
-create dns_resolver * * /sbin/key.dns_resolver %k
-create user debug:* negate /bin/keyctl negate %k 30 %S
-create user debug:* rejected /bin/keyctl reject %k 30 %c %S
-create user debug:* expired /bin/keyctl reject %k 30 %c %S
-create user debug:* revoked /bin/keyctl reject %k 30 %c %S
-create user debug:loop:* * |/bin/cat
+create dns_resolver * * /usr/sbin/key.dns_resolver %k
+create user debug:* negate /usr/bin/keyctl negate %k 30 %S
+create user debug:* rejected /usr/bin/keyctl reject %k 30 %c %S
+create user debug:* expired /usr/bin/keyctl reject %k 30 %c %S
+create user debug:* revoked /usr/bin/keyctl reject %k 30 %c %S
+create user debug:loop:* * |/usr/bin/cat
create user debug:* * /usr/share/keyutils/request-key-debug.sh %k %d %c %S
-negate * * * /bin/keyctl negate %k 30 %S
+negate * * * /usr/bin/keyctl negate %k 30 %S