libassuan/PKGBUILD
2024-11-05 19:49:33 +08:00

38 lines
1.3 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <futurelinux@163.com>
pkgname=libassuan
pkgver=3.0.1
pkgrel=1
pkgdesc="IPC library used by some GnuPG related software"
arch=('x86_64')
url="https://www.gnupg.org/related_software/libassuan/"
license=('GPL3')
depends=('glibc' 'libgpg-error' 'bash')
source=(https://www.gnupg.org/ftp/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
sha256sums=(c8f0f42e6103dea4b1a6a483cb556654e97302c7465308f58363778f95f194b1)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE}
make -C doc html
makeinfo --html --no-split -o doc/assuan_nochunks.html doc/assuan.texi
makeinfo --plaintext -o doc/assuan.txt doc/assuan.texi
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
install -v -dm755 ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/html
install -v -m644 doc/assuan.html/* ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/html
install -v -m644 doc/assuan_nochunks.html ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
install -v -m644 doc/assuan.{txt,texi} ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
}