libcap 2.71-1
This commit is contained in:
parent
91674bd72e
commit
68bbab5dc0
10
PKGBUILD
10
PKGBUILD
@ -5,7 +5,7 @@
|
||||
|
||||
# Maintainer: Future Linux Team <future_linux@163.com>
|
||||
pkgname=libcap
|
||||
pkgver=2.70
|
||||
pkgver=2.71
|
||||
pkgrel=1
|
||||
pkgdesc="POSIX 1003.1e capabilities"
|
||||
arch=('x86_64')
|
||||
@ -15,9 +15,9 @@ depends=('glibc' 'gcc-libs' 'linux-pam')
|
||||
makedepends=('linux-api-headers' 'go')
|
||||
options=('!lto')
|
||||
source=(https://www.kernel.org/pub/linux/libs/security/linux-privs/libcap2/${pkgname}-${pkgver}.tar.xz
|
||||
libcap-2.69-cgo_flags.patch)
|
||||
sha256sums=(23a6ef8aadaf1e3e875f633bb2d116cfef8952dba7bc7c569b13458e1952b30f
|
||||
f7c0e863879c76a1fd20654932e8b13af64405ce969c5cae52a75731b6ea8a2e)
|
||||
libcap-2.71-cgo-flags.patch)
|
||||
sha256sums=(b7006c9af5168315f35fc734bf1a8d2aa70766bd8b8c4340962e05b19c35b900
|
||||
436594bed416dfa1a3a3a9df17350555c1f995d480d0ebbb739d7a29656ccc5a)
|
||||
|
||||
# NOTE: with CGO_ENABLED we need all relevant make options in build(), check() and package() otherwise the package is not reproducible
|
||||
_common_make_options=(
|
||||
@ -34,7 +34,7 @@ prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
||||
# ensure to use CGO_ENABLED all the way (so that we can have full RELRO)
|
||||
patch -Np1 -i ${srcdir}/libcap-2.69-cgo_flags.patch
|
||||
patch -Np1 -i ${srcdir}/libcap-2.71-cgo-flags.patch
|
||||
|
||||
}
|
||||
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -ruN a/go/Makefile b/go/Makefile
|
||||
--- a/go/Makefile 2022-10-10 01:01:27.000000000 +0200
|
||||
+++ b/go/Makefile 2024-03-19 12:33:19.217467384 +0100
|
||||
@@ -68,19 +68,19 @@
|
||||
diff --git i/go/Makefile w/go/Makefile
|
||||
index d0b081d..ba3a357 100644
|
||||
--- i/go/Makefile
|
||||
+++ w/go/Makefile
|
||||
@@ -68,19 +68,19 @@ ifeq ($(RAISE_GO_FILECAP),yes)
|
||||
endif
|
||||
|
||||
setid: ../goapps/setid/setid.go CAPGOPACKAGE PSXGOPACKAGE
|
||||
@ -21,8 +22,8 @@ diff -ruN a/go/Makefile b/go/Makefile
|
||||
+ CC="$(CC)" CGO_ENABLED="$(CGO_REQUIRED)" $(CGO_LDFLAGS_ALLOW) CGO_CFLAGS="$(CGO_CFLAGS)" CGO_CPPFLAGS="$(CGO_CPPFLAGS)" CGO_CXXFLAGS="$(CGO_CXXFLAGS)" CGO_LDFLAGS="$(CGO_LDFLAGS)" $(GO) build $(GO_BUILD_FLAGS) $(GOFLAGS) -mod=vendor -o $@ $<
|
||||
|
||||
ok: ok.go vendor/modules.txt
|
||||
- CC="$(CC)" CGO_ENABLED="0" $(GO) build $(GO_BUILD_FLAGS) -mod=vendor $<
|
||||
+ CC="$(CC)" CGO_ENABLED="$(CGO_REQUIRED)" $(GO) build $(GO_BUILD_FLAGS) -mod=vendor $<
|
||||
- CC="$(CC)" CGO_ENABLED="0" $(GO) build $(GO_BUILD_FLAGS) -mod=vendor $<
|
||||
+ CC="$(CC)" CGO_ENABLED="$(CGO_REQUIRED)" $(GO) build $(GO_BUILD_FLAGS) $(GOFLAGS) -mod=vendor $<
|
||||
|
||||
try-launching: try-launching.go CAPGOPACKAGE ok
|
||||
CC="$(CC)" CGO_ENABLED="$(CGO_REQUIRED)" $(CGO_LDFLAGS_ALLOW) $(GO) build $(GO_BUILD_FLAGS) -mod=vendor $<
|
Loading…
Reference in New Issue
Block a user