36 lines
1.0 KiB
Bash
36 lines
1.0 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libevdev
|
|
pkgver=1.13.1
|
|
pkgrel=1
|
|
pkgdesc="Wrapper library for evdev devices"
|
|
arch=('x86_64')
|
|
url="https://www.freedesktop.org/wiki/Software/libevdev"
|
|
license=('custom:MIT')
|
|
depends=('glibc')
|
|
makedepends=('python' 'check' 'meson')
|
|
source=(https://www.freedesktop.org/software/${pkgname}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(06a77bf2ac5c993305882bc1641017f5bec1592d6d1b64787bad492ab34f2f36)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson setup build \
|
|
--prefix=/usr \
|
|
--buildtype=release \
|
|
-Dlibdir=/usr/lib64 \
|
|
-Ddocumentation=disabled
|
|
|
|
meson compile -C build
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson install -C build --destdir ${pkgdir}
|
|
}
|