36 lines
930 B
Bash
36 lines
930 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libfs
|
|
pkgver=1.0.9
|
|
pkgrel=1
|
|
pkgdesc="X11 Font Server client library"
|
|
arch=('x86_64')
|
|
url="http://xorg.freedesktop.org"
|
|
license=('custom')
|
|
depends=('glibc')
|
|
makedepends=('util-macros' 'xorgproto' 'xtrans')
|
|
source=(https://www.x.org/pub/individual/lib/libFS-${pkgver}.tar.xz)
|
|
sha256sums=(597379438b3242ccc7d7b0fc432dc6c844eca0d4a82a7b82518bfeb203fc208a)
|
|
|
|
build() {
|
|
cd libFS-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/libFS-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libFS-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|