libglvnd/PKGBUILD
2024-10-23 20:13:45 +08:00

39 lines
1.1 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=libglvnd
pkgver=1.7.0
pkgrel=1
pkgdesc="The GL Vendor-Neutral Dispatch library"
arch=('x86_64')
url="https://gitlab.freedesktop.org/glvnd/libglvnd"
license=('custom:BSD-like')
depends=('libxext' 'mesa')
makedepends=('libx11' 'xorgproto' 'python' 'meson')
backup=()
options=()
install=
source=(https://gitlab.freedesktop.org/glvnd/libglvnd/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.bz2)
sha256sums=(d0e1925a3c9aee0143b8c181ac31d5637c8faa081759c277b8e16c7075612c11)
build() {
cd ${pkgname}-v${pkgver}
future-meson build \
--prefix=/usr \
--libdir=/usr/lib64 \
--buildtype=release \
-Dgles1=false
meson compile -C build
}
package() {
cd ${pkgname}-v${pkgver}
meson install -C build --destdir ${pkgdir}
}