libinput/PKGBUILD
2024-04-16 23:01:27 +08:00

38 lines
1.1 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=libinput
pkgver=1.25.0
pkgrel=1
pkgdesc="Input device management and event handling library"
arch=('x86_64')
url="https://wayland.freedesktop.org/libinput/doc/${pkgver}/"
license=('MIT')
depends=('mtdev' 'systemd' 'libevdev' 'glibc')
makedepends=('meson' 'wayland-protocols')
source=(https://gitlab.freedesktop.org/libinput/libinput/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
sha256sums=(f7e8425f185cadba5761d0a1dae6be041750d351163ffa04adc5b9a79a13c0ec)
build() {
cd ${pkgname}-${pkgver}
meson setup build \
--prefix=/usr \
--buildtype=release \
-Ddebug-gui=false \
-Dtests=false \
-Dlibwacom=false \
-Dudev-dir=/usr/lib/udev
meson compile -C build
}
package() {
cd ${pkgname}-${pkgver}
meson install -C build --destdir ${pkgdir}
}