31 lines
907 B
Bash
31 lines
907 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <futurelinux@163.com>
|
|
pkgname=libksba
|
|
pkgver=1.6.7
|
|
pkgrel=1
|
|
pkgdesc="Library for working with X.509 certificates, CMS data and related objects"
|
|
arch=('x86_64')
|
|
url="https://www.gnupg.org/related_software/libksba/"
|
|
license=('GPL-2.0-only' 'GPL-3.0-only' 'LGPL-3.0-only')
|
|
depends=('bash' 'libgpg-error' 'glibc')
|
|
source=(https://www.gnupg.org/ftp/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
|
|
sha256sums=(cf72510b8ebb4eb6693eef765749d83677a03c79291a311040a5bfd79baab763)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|