libmicrohttpd/PKGBUILD
2024-10-16 02:23:18 +08:00

34 lines
899 B
Bash

# Maintainer: Future Linux Team <futurelinux@163.com>
pkgname=libmicrohttpd
pkgver=1.0.1
pkgrel=1
pkgdesc="a small C library that is supposed to make it easy to run an HTTP server as part of another application."
arch=('x86_64')
url="https://www.gnu.org/software/libmicrohttpd/"
license=('LGPL')
depends=('gnutls')
source=(https://ftp.gnu.org/gnu/libmicrohttpd/${pkgname}-${pkgver}.tar.gz)
sha256sums=(a89e09fc9b4de34dde19f4fcb4faaa1ce10299b9908db1132bbfa1de47882b94)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} \
--disable-dependency-tracking \
--disable-examples \
--enable-curl \
--enable-https \
--enable-largefile \
--enable-messages \
--with-pic
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}