33 lines
921 B
Bash
33 lines
921 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libnghttp2
|
|
pkgver=1.60.0
|
|
pkgrel=1
|
|
pkgdesc="Framing layer of HTTP/2 is implemented as a reusable C library"
|
|
arch=('x86_64')
|
|
url="https://nghttp2.org/"
|
|
license=('MIT')
|
|
depends=('glibc')
|
|
source=(https://github.com/nghttp2/nghttp2/releases/download/v${pkgver}/${pkgname#lib}-${pkgver}.tar.xz)
|
|
sha256sums=(625d6c3da1d9ca4fd643a638256431ae68fd1901653b2a61a245eea7b261bf4e)
|
|
|
|
build() {
|
|
cd ${pkgname#lib}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--disable-static \
|
|
--enable-lib-only
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname#lib}-${pkgver}
|
|
|
|
make -C lib DESTDIR=${pkgdir} install
|
|
}
|