libnghttp3/PKGBUILD
2024-11-04 19:29:03 +08:00

37 lines
861 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=libnghttp3
pkgver=1.6.0
pkgrel=1
pkgdesc="HTTP/3 library written in C"
arch=('x86_64')
url="https://github.com/ngtcp2/nghttp3"
license=('MIT')
depends=('glibc')
source=(https://github.com/ngtcp2/nghttp3/releases/download/v${pkgver}/nghttp3-${pkgver}.tar.xz)
sha256sums=(eaa901954bc494034d3738ef19130de69387d6a3da029044c60d9dae91792a8d)
prepare() {
cd nghttp3-${pkgver}
autoreconf -i
}
build() {
cd nghttp3-${pkgver}
${CONFIGURE}
make
}
package() {
cd nghttp3-${pkgver}/lib
make DESTDIR=${pkgdir} install
}