37 lines
903 B
Bash
37 lines
903 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libnsl
|
|
pkgver=2.0.1
|
|
pkgrel=1
|
|
pkgdesc="Public client interface library for NIS(YP)"
|
|
arch=('x86_64')
|
|
url="https://github.com/thkukuk/libnsl"
|
|
license=('LGPL-2.1-only')
|
|
depends=('glibc' 'libtirpc')
|
|
source=(https://github.com/thkukuk/libnsl/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(5c9e470b232a7acd3433491ac5221b4832f0c71318618dc6aa04dd05ffcd8fd9)
|
|
|
|
prepare() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
autoreconf -fiv
|
|
}
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} --disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|