31 lines
824 B
Bash
31 lines
824 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libogg
|
|
pkgver=1.3.5
|
|
pkgrel=1
|
|
pkgdesc="Ogg bitstream and framing library"
|
|
arch=('x86_64')
|
|
url="https://www.xiph.org/ogg"
|
|
license=('BSD')
|
|
depends=('glibc')
|
|
source=(https://downloads.xiph.org/releases/ogg/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(c4d91be36fc8e54deae7575241e03f4211eb102afb3fc0775fbbc1b740016705)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} --disable-static --docdir=/usr/share/doc/${pkgname}-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|