35 lines
969 B
Bash
35 lines
969 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libpciaccess
|
|
pkgver=0.18.1
|
|
pkgrel=1
|
|
pkgdesc="X11 PCI access library"
|
|
arch=('x86_64')
|
|
url="https://gitlab.freedesktop.org/xorg/lib/libpciaccess"
|
|
license=('LicenseRef-libpciaccess')
|
|
depends=('glibc' 'zlib')
|
|
makedepends=('util-macros' 'meson')
|
|
source=(https://www.x.org/pub/individual/lib/libpciaccess-${pkgver}.tar.xz)
|
|
sha256sums=(4af43444b38adb5545d0ed1c2ce46d9608cc47b31c2387fc5181656765a6fa76)
|
|
|
|
build() {
|
|
cd libpciaccess-${pkgver}
|
|
|
|
meson setup build \
|
|
--prefix=/usr \
|
|
--buildtype=release \
|
|
-Dlibdir=/usr/lib64
|
|
|
|
meson compile -C build
|
|
}
|
|
|
|
package() {
|
|
cd libpciaccess-${pkgver}
|
|
|
|
meson install -C build --destdir ${pkgdir}
|
|
}
|