libseccomp/PKGBUILD
2024-11-03 21:55:59 +08:00

53 lines
1.3 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=(libseccomp python-libseccomp)
pkgbase=libseccomp
pkgver=2.5.5
pkgrel=2
pkgdesc="Enhanced seccomp library"
arch=('x86_64')
url="https://github.com/seccomp/libseccomp"
license=('LGPL2.1')
depends=('glibc' 'python')
makedepends=('gperf' 'python-cython' 'python-setuptools')
source=(https://github.com/seccomp/libseccomp/releases/download/v${pkgver}/${pkgbase}-${pkgver}.tar.gz)
sha256sums=(248a2c8a4d9b9858aa6baf52712c34afefcf9c9e94b76dce02c1c9aa25fb3375)
prepare() {
cd ${pkgbase}-${pkgver}
autoreconf -fiv
}
build() {
cd ${pkgbase}-${pkgver}
#${CONFIGURE} --disable-static
${CONFIGURE}
make
(
cd src/python
env VERSION_RELEASE=${pkgver} python3 setup.py build
)
}
package_libseccomp() {
cd ${pkgbase}-${pkgver}
make DESTDIR=${pkgdir} install
}
package_python-libseccomp() {
depends=('python')
cd ${pkgbase}-${pkgver}/src/python
env VERSION_RELEASE=${pkgver} python3 setup.py install --root=${pkgdir} --prefix=/usr -O1 --skip-build
}