libsm/PKGBUILD
2024-04-15 13:47:14 +08:00

36 lines
933 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=libsm
pkgver=1.2.4
pkgrel=1
pkgdesc="X11 Session Management library"
arch=('x86_64')
url="https://xorg.freedesktop.org/"
license=('custom')
depends=('libice')
makedepends=('util-macros' 'xtrans' 'xorgproto')
source=(https://www.x.org/pub/individual/lib/libSM-${pkgver}.tar.xz)
sha256sums=(fdcbe51e4d1276b1183da77a8a4e74a137ca203e0bcfb20972dd5f3347e97b84)
build() {
cd libSM-${pkgver}
${CONFIGURE} \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static \
--docdir=/usr/share/doc/libSM-${pkgver}
make
}
package() {
cd libSM-${pkgver}
make DESTDIR=${pkgdir} install
}