46 lines
1.2 KiB
Bash
46 lines
1.2 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libssh2
|
|
pkgver=1.11.0
|
|
pkgrel=1
|
|
pkgdesc="A library implementing the SSH2 protocol as defined by Internet Drafts"
|
|
arch=('x86_64')
|
|
url="https://www.libssh2.org"
|
|
license=('BSD')
|
|
depends=('openssl' 'zlib')
|
|
source=(https://www.libssh2.org/download/${pkgname}-${pkgver}.tar.gz
|
|
${pkgname}-${pkgver}-security_fixes-1.patch)
|
|
sha256sums=(3736161e41e2693324deb38c26cfdc3efe6209d634ba4258db1cecff6a5ad461
|
|
b9ea9cb1b06652e31cf2f56f8d7f85b702ebf4e967e6fdafe2ffbd556f4a0c02)
|
|
|
|
prepare() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
patch -Np1 -i ${srcdir}/${pkgname}-${pkgver}-security_fixes-1.patch
|
|
|
|
sed -E '/^DOCKER_TEST/,/^SSHD_TEST/s/test_(auth_keyboard_info.* |hostkey |simple)/$(NOTHING)/' \
|
|
-i tests/Makefile.inc
|
|
|
|
autoreconf -fi
|
|
}
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--disable-docker-tests \
|
|
--disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|