44 lines
1.0 KiB
Bash
44 lines
1.0 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libtheora
|
|
pkgver=1.1.1
|
|
pkgrel=1
|
|
pkgdesc="Standard encoder and decoder library for the Theora video compression format"
|
|
arch=('x86_64')
|
|
url="https://www.theora.org/"
|
|
license=('BSD-3-Clause')
|
|
depends=('glibc' 'libogg')
|
|
makedepends=('libpng' 'libvorbis' 'sdl12-compat' 'git')
|
|
source=(git+https://github.com/xiph/theora.git#tag=v${pkgver})
|
|
sha256sums=(SKIP)
|
|
|
|
prepare() {
|
|
cd theora
|
|
|
|
# Fix for autoreconf
|
|
git cherry-pick -n 28cc6dbd9b2a141df94f60993256a5fca368fa54
|
|
|
|
# Fix build with libpng 1.6
|
|
git cherry-pick -n 7288b539c52e99168488dc3a343845c9365617c8
|
|
|
|
autoreconf -fi
|
|
}
|
|
|
|
build() {
|
|
cd theora
|
|
|
|
${CONFIGURE} --enable-shared --disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd theora
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|