35 lines
986 B
Bash
35 lines
986 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libtirpc
|
|
pkgver=1.3.5
|
|
pkgrel=1
|
|
pkgdesc="Transport Independent RPC library (SunRPC replacement)"
|
|
arch=('x86_64')
|
|
url="http://git.linux-nfs.org/?p=steved/libtirpc.git;a=summary"
|
|
license=('SISSL' 'BSD-3-Clause')
|
|
depends=('krb5' 'glibc')
|
|
backup=(etc/netconfig)
|
|
source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
|
|
sha256sums=(9b31370e5a38d3391bf37edfa22498e28fe2142467ae6be7a17c9068ec0bf12f)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--disable-static
|
|
|
|
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|