34 lines
949 B
Bash
34 lines
949 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libvorbis
|
|
pkgver=1.3.7
|
|
pkgrel=1
|
|
pkgdesc="Reference implementation of the Ogg Vorbis audio format"
|
|
arch=('x86_64')
|
|
url="https://www.xiph.org/vorbis"
|
|
license=('GPL')
|
|
depends=('libogg')
|
|
source=(https://downloads.xiph.org/releases/vorbis/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(b33cc4934322bcbf6efcbacf49e3ca01aadbea4114ec9589d1b1e9d20f72954b)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} --disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
|
|
install -vdm755 ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
|
|
install -v -m644 doc/Vorbis* ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
|
|
}
|