libx11/PKGBUILD
2024-04-15 10:49:25 +08:00

34 lines
909 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=libx11
pkgver=1.8.9
pkgrel=1
pkgdesc="X11 client-side library"
arch=('x86_64')
url="https://xorg.freedesktop.org/"
license=('custom')
depends=('glibc' 'libxcb' 'libxau' 'libxdmcp')
makedepends=('util-macros' 'xorgproto' 'xtrans')
source=(https://www.x.org/pub/individual/lib/libX11-${pkgver}.tar.xz)
sha256sums=(779d8f111d144ef93e2daa5f23a762ce9555affc99592844e71c4243d3bd3262)
build() {
cd libX11-${pkgver}
${CONFIGURE} \
--disable-static \
--docdir=/usr/share/doc/libX11-${pkgver}
make
}
package() {
cd libX11-${pkgver}
make DESTDIR=${pkgdir} install
}