libxaw/PKGBUILD
2024-04-15 14:43:18 +08:00

41 lines
1.0 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=libxaw
pkgver=1.0.16
pkgrel=1
pkgdesc="X11 Athena Widget library"
arch=('x86_64')
url="https://xorg.freedesktop.org/"
license=('MIT-open-group'
'X11'
'HPND'
'HPND-sell-variant'
'SMLNJ'
'NTP')
depends=('libxmu' 'libxpm' 'libx11' 'libxt' 'libxext' 'xorgproto' 'glibc')
makedepends=('util-macros')
source=(https://www.x.org/pub/individual/lib/libXaw-${pkgver}.tar.xz)
sha256sums=(731d572b54c708f81e197a6afa8016918e2e06dfd3025e066ca642a5b8c39c8f)
build() {
cd libXaw-${pkgver}
${CONFIGURE} \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static \
--docdir=/usr/share/doc/libXaw-${pkgver}
make
}
package() {
cd libXaw-${pkgver}
make DESTDIR=${pkgdir} install
}