35 lines
994 B
Bash
35 lines
994 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxcb
|
|
pkgver=1.16.1
|
|
pkgrel=1
|
|
pkgdesc="X11 client-side library"
|
|
arch=('x86_64')
|
|
url="https://xcb.freedesktop.org/"
|
|
license=('X11')
|
|
depends=('xcb-proto' 'libxdmcp' 'libxau' 'glibc')
|
|
makedepends=('libxslt' 'python' 'util-macros' 'xorgproto')
|
|
source=(https://xorg.freedesktop.org/archive/individual/lib/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(f24d187154c8e027b358fc7cb6588e35e33e6a92f11c668fe77396a7ae66e311)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--disable-static \
|
|
--without-doxygen \
|
|
--docdir=/usr/share/doc/${pkgname}-${pkgver}
|
|
|
|
LC_ALL=en_US.UTF-8 make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|