35 lines
1013 B
Bash
35 lines
1013 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxcvt
|
|
pkgver=0.1.2
|
|
pkgrel=1
|
|
pkgdesc="library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator"
|
|
arch=('x86_64')
|
|
url="https://gitlab.freedesktop.org/xorg/lib/libxcvt"
|
|
license=('custom')
|
|
depends=('glibc')
|
|
makedepends=('meson')
|
|
source=(https://www.x.org/pub/individual/lib/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(0561690544796e25cfbd71806ba1b0d797ffe464e9796411123e79450f71db38)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson setup build \
|
|
--prefix=/usr \
|
|
--buildtype=release \
|
|
-Dlibdir=/usr/lib64
|
|
|
|
meson compile -C build
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson install -C build --destdir ${pkgdir}
|
|
}
|