36 lines
944 B
Bash
36 lines
944 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxdamage
|
|
pkgver=1.1.6
|
|
pkgrel=1
|
|
pkgdesc="X11 damaged region extension library"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('custom')
|
|
depends=('libxfixes')
|
|
makedepends=('xorgproto')
|
|
source=(https://www.x.org/pub/individual/lib/libXdamage-${pkgver}.tar.xz)
|
|
sha256sums=(52733c1f5262fca35f64e7d5060c6fcd81a880ba8e1e65c9621cf0727afb5d11)
|
|
|
|
build() {
|
|
cd libXdamage-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/libXdamage-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libXdamage-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|