36 lines
957 B
Bash
36 lines
957 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxfixes
|
|
pkgver=6.0.1
|
|
pkgrel=1
|
|
pkgdesc="X11 miscellaneous 'fixes' extension library"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('custom')
|
|
depends=('libx11')
|
|
makedepends=('util-macros' 'xorgproto')
|
|
source=(https://www.x.org/pub/individual/lib/libXfixes-${pkgver}.tar.xz)
|
|
sha256sums=(b695f93cd2499421ab02d22744458e650ccc88c1d4c8130d60200213abc02d58)
|
|
|
|
build() {
|
|
cd libXfixes-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/libXfixes-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libXfixes-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|