37 lines
994 B
Bash
37 lines
994 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxfont2
|
|
pkgver=2.0.6
|
|
pkgrel=1
|
|
pkgdesc="X11 font rasterisation library"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('custom')
|
|
depends=('freetype2' 'libfontenc' 'xorgproto')
|
|
makedepends=('util-macros' 'xtrans')
|
|
source=(https://www.x.org/pub/individual/lib/libXfont2-${pkgver}.tar.xz)
|
|
sha256sums=(74ca20017eb0fb3f56d8d5e60685f560fc85e5ff3d84c61c4cb891e40c27aef4)
|
|
|
|
build() {
|
|
cd libXfont2-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--disable-devel-docs \
|
|
--docdir=/usr/share/doc/libXfont2-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libXfont2-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|