37 lines
940 B
Bash
37 lines
940 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxpm
|
|
pkgver=3.5.17
|
|
pkgrel=1
|
|
pkgdesc="X11 pixmap library"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('custom')
|
|
depends=('libxt' 'libxext')
|
|
makedepends=('util-macros')
|
|
source=(https://www.x.org/pub/individual/lib/libXpm-${pkgver}.tar.xz)
|
|
sha256sums=(64b31f81019e7d388c822b0b28af8d51c4622b83f1f0cb6fa3fc95e271226e43)
|
|
|
|
build() {
|
|
cd libXpm-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--disable-open-zfile \
|
|
--docdir=/usr/share/doc/libXpm-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libXpm-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|