36 lines
988 B
Bash
36 lines
988 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxpresent
|
|
pkgver=1.0.1
|
|
pkgrel=1
|
|
pkgdesc="X Present Extension library"
|
|
arch=('x86_64')
|
|
url="https://gitlab.freedesktop.org/xorg/lib/libxpresent"
|
|
license=('custom')
|
|
depends=('libxfixes' 'libxrandr')
|
|
makedepends=('util-macros' 'xorgproto')
|
|
source=(https://www.x.org/pub/individual/lib/libXpresent-${pkgver}.tar.xz)
|
|
sha256sums=(b964df9e5a066daa5e08d2dc82692c57ca27d00b8cc257e8e960c9f1cf26231b)
|
|
|
|
build() {
|
|
cd libXpresent-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/libXpresent-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libXpresent-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|