36 lines
1.0 KiB
Bash
36 lines
1.0 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxscrnsaver
|
|
pkgver=1.2.4
|
|
pkgrel=1
|
|
pkgdesc="libXScrnSaver contains the X.org screen saver library"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('MIT')
|
|
depends=('glibc' 'libxcb' 'libx11' 'libxau' 'libxdmcp' 'libxext')
|
|
makedepends=('util-macros' 'xorgproto' 'libice' 'xtrans')
|
|
source=(https://www.x.org/pub/individual/lib/libXScrnSaver-${pkgver}.tar.xz)
|
|
sha256sums=(75cd2859f38e207a090cac980d76bc71e9da99d48d09703584e00585abc920fe)
|
|
|
|
build() {
|
|
cd libXScrnSaver-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/libXScrnSaver-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libXScrnSaver-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|