36 lines
983 B
Bash
36 lines
983 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxshmfence
|
|
pkgver=1.3.2
|
|
pkgrel=1
|
|
pkgdesc="a library that exposes a event API on top of Linux futexes"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('GPL')
|
|
depends=('glibc')
|
|
makedepends=('util-macros' 'xorgproto')
|
|
source=(https://www.x.org/pub/individual/lib/libxshmfence-${pkgver}.tar.xz)
|
|
sha256sums=(870df257bc40b126d91b5a8f1da6ca8a524555268c50b59c0acd1a27f361606f)
|
|
|
|
build() {
|
|
cd libxshmfence-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/libxshmfence-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libxshmfence-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|