36 lines
909 B
Bash
36 lines
909 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxv
|
|
pkgver=1.0.12
|
|
pkgrel=1
|
|
pkgdesc="X11 Video extension library"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('custom')
|
|
depends=('libxext')
|
|
makedepends=('xorgproto')
|
|
source=(https://www.x.org/pub/individual/lib/libXv-${pkgver}.tar.xz)
|
|
sha256sums=(aaf7fa09f689f7a2000fe493c0d64d1487a1210db154053e9e2336b860c63848)
|
|
|
|
build() {
|
|
cd libXv-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/libXv-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libXv-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|