libxvmc/PKGBUILD
2024-04-15 21:12:03 +08:00

37 lines
1.0 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=libxvmc
pkgver=1.0.14
pkgrel=1
pkgdesc="X11 Video Motion Compensation extension library"
arch=('x86_64')
url="https://gitlab.freedesktop.org/xorg/lib/libxvmc"
license=('LicenseRef-libxvmc')
depends=('glibc' 'libxcb' 'libx11' 'libxau' 'libxdmcp' 'libxext' 'libxv')
depends=('libxext' 'libxv' 'libx11')
makedepends=('util-macros' 'xorgproto')
source=(https://www.x.org/pub/individual/lib/libXvMC-${pkgver}.tar.xz)
sha256sums=(e4be9eb6b6bafdbbf81f47f7163047215376e45e2dc786d0ea6181c930725ed9)
build() {
cd libXvMC-${pkgver}
${CONFIGURE} \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static \
--docdir=/usr/share/doc/libXvMC-${pkgver}
make
}
package() {
cd libXvMC-${pkgver}
make DESTDIR=${pkgdir} install
}