36 lines
1.0 KiB
Bash
36 lines
1.0 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxxf86dga
|
|
pkgver=1.1.6
|
|
pkgrel=1
|
|
pkgdesc="libXxf86dga contains the X.org direct graphics access extension library"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org"
|
|
license=('MIT')
|
|
depends=('libxcb' 'libx11' 'libxau' 'libxdmcp' 'libxext')
|
|
makedepends=('xorgproto' 'util-macros')
|
|
source=(https://www.x.org/pub/individual/lib/libXxf86dga-${pkgver}.tar.xz)
|
|
sha256sums=(be44427579808fe3a217d59f51cae756a26913eb6e4c8738ccab65ff56d7980f)
|
|
|
|
build() {
|
|
cd libXxf86dga-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/libXxf86dga-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libXxf86dga-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|