36 lines
960 B
Bash
36 lines
960 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libxxf86vm
|
|
pkgver=1.1.5
|
|
pkgrel=1
|
|
pkgdesc="X11 XFree86 video mode extension library"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('custom')
|
|
depends=('libxext')
|
|
makedepends=('util-macros' 'xorgproto')
|
|
source=(https://www.x.org/pub/individual/lib/libXxf86vm-${pkgver}.tar.xz)
|
|
sha256sums=(247fef48b3e0e7e67129e41f1e789e8d006ba47dba1c0cdce684b9b703f888e7)
|
|
|
|
build() {
|
|
cd libXxf86vm-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/libXxf86vm-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd libXxf86vm-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|