33 lines
1.0 KiB
Bash
33 lines
1.0 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=make-ca
|
|
pkgver=1.14
|
|
pkgrel=1
|
|
pkgdesc="The Grep package contains programs for searching through files"
|
|
arch=('x86_64')
|
|
url="https://github.com/lfs-book/make-ca"
|
|
license=('MIT' 'GPL3')
|
|
depends=('openssl' 'libp11-kit' 'systemd')
|
|
install=${pkgname}.install
|
|
source=(https://github.com/lfs-book/make-ca/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(6391698fe6db16eb190da1aba802bc90c09c8baa4c116d9c65647bea87f190db)
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
|
|
install -vdm755 ${pkgdir}/etc/profile.d
|
|
cat > ${pkgdir}/etc/profile.d/pythoncerts.sh << "EOF"
|
|
# Begin /etc/profile.d/pythoncerts.sh
|
|
|
|
export _PIP_STANDALONE_CERT=/etc/pki/tls/certs/ca-bundle.crt
|
|
|
|
# End /etc/profile.d/pythoncerts.sh
|
|
EOF
|
|
}
|