31 lines
858 B
Bash
31 lines
858 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=mtdev
|
|
pkgver=1.1.7
|
|
pkgrel=1
|
|
pkgdesc="A stand-alone library which transforms all variants of kernel MT events to the slotted type B protocol"
|
|
arch=('x86_64')
|
|
url="https://bitmath.org/code/mtdev/"
|
|
license=('custom:MIT')
|
|
depends=('glibc')
|
|
source=(https://bitmath.org/code/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
|
|
sha256sums=(a107adad2101fecac54ac7f9f0e0a0dd155d954193da55c2340c97f2ff1d814e)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} --disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|