nasm/PKGBUILD
2024-04-17 09:45:35 +08:00

37 lines
1.1 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=nasm
pkgver=2.16.02
pkgrel=1
pkgdesc="80x86 assembler designed for portability and modularity"
arch=('x86_64')
url="https://www.nasm.us"
license=('BSD')
depends=('glibc')
source=(https://www.nasm.us/pub/nasm/releasebuilds/${pkgver}/${pkgname}-${pkgver}.tar.xz
https://www.nasm.us/pub/nasm/releasebuilds/${pkgver}/${pkgname}-${pkgver}-xdoc.tar.xz)
sha256sums=(1e1b942ea88f22edae89659e15be26fa027eae0747f51413540f52d4eac4790d
45fe7c1abd55045e10a4e97319ff393710321288eec6ea4f9ecc77b95665a8c4)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE}
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
install -m755 -d ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/html
cp -v doc/html/*.html ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/html
cp -v doc/*.{txt,ps,pdf} ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
}