python-alabaster/PKGBUILD

30 lines
978 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-alabaster
pkgver=0.7.16
pkgrel=1
pkgdesc="Lightweight, configurable Sphinx theme"
arch=('x86_64')
url="https://pypi.org/project/alabaster/"
license=('BSD-3-Clause')
depends=('python')
makedepends=('python-build' 'python-wheel' 'python-installer' 'python-flit-core')
source=(https://files.pythonhosted.org/packages/source/a/${pkgname#*-}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(75a8b99c28a5dad50dd7f8ccdd447a121ddb3892da9e53d1ca5cca3106d58d65)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m build --wheel --no-isolation --skip-dependency-check
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}