python-appdirs/PKGBUILD
2024-10-16 01:03:54 +08:00

30 lines
999 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-appdirs
pkgver=1.4.4
pkgrel=1
pkgdesc="A small Python module for determining appropriate platform-specific dirs, e.g. a "user data dir"."
arch=('x86_64')
url="https://github.com/ActiveState/appdirs"
license=('MIT')
depends=('python')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=(https://github.com/ActiveState/appdirs/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(6db10570b4f0176a05924c20745ff73385497e57829634fb3e756e15636ff408)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m build --wheel --no-isolation
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}