python-breezy/PKGBUILD
2024-10-29 23:35:19 +08:00

53 lines
1.4 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-breezy
pkgver=3.3.9
pkgrel=1
pkgdesc="A decentralized revision control system with support for Bazaar and Git file formats"
arch=('x86_64')
url="https://www.breezy-vcs.org"
license=('GPL-2.0-or-later')
depends=(
'gcc-libs'
'glibc'
'python'
'python-configobj'
'python-dulwich'
'python-fastbencode'
'python-merge3'
'python-patiencediff'
'python-pyyaml'
)
makedepends=(
'python-cython'
'python-build'
'python-fastimport'
'python-gpgme'
'python-installer'
'python-packaging'
'python-paramiko'
'python-setuptools'
'python-setuptools-gettext'
'python-setuptools-rust'
'python-wheel')
source=(https://launchpad.net/brz/${pkgver%.*}/${pkgver}/+download/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(c2588bf217c8a4056987ecf6599f0ad9fb8484285953b2e61905141f43c3d5d8)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m build --wheel --no-isolation
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
ln -s brz ${pkgdir}/usr/bin/bzr # backwards compatibility
}