38 lines
1.1 KiB
Bash
38 lines
1.1 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=python-cython
|
|
pkgver=3.0.11
|
|
pkgrel=1
|
|
pkgdesc="C-Extensions for Python"
|
|
arch=('x86_64')
|
|
url="https://cython.org"
|
|
license=('Apache-2.0')
|
|
depends=('glibc' 'python')
|
|
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
|
|
source=(https://github.com/cython/cython/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz
|
|
numpy-2.patch)
|
|
sha256sums=(2ec7d66d23d6da2328fb24f5c1bec6c63a59ec2e91027766ab904f417e1078aa
|
|
6f98a6cc46d0d65a01a1fb5ac9f40e6d2612f80a34ad8e95bd9ad1116e24855d)
|
|
|
|
prepare() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
patch -Np1 -i ${srcdir}/numpy-2.patch # Fix tests with numpy 2
|
|
}
|
|
|
|
build() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m build --wheel --no-isolation
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m installer --destdir=${pkgdir} dist/*.whl
|
|
}
|