python-dulwich/PKGBUILD
2024-10-29 23:36:04 +08:00

30 lines
1.1 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-dulwich
pkgver=0.22.2
pkgrel=1
pkgdesc="Pure-Python implementation of the Git file formats and protocols"
arch=('x86_64')
url="https://www.dulwich.io"
license=('Apache-2.0 OR GPL-2.0-or-later')
depends=('python-urllib3')
makedepends=('python-build' 'python-installer' 'python-setuptools-rust' 'python-wheel')
source=(https://github.com/jelmer/dulwich/archive/${pkgname#*-}-${pkgver}/${pkgname#*-}-${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(dbf3d537dca81cb5d95fb95ec45222b51df11db5d4d45e9c11ded372f95f539c)
build() {
cd ${pkgname#*-}-${pkgname#*-}-${pkgver}
python3 -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${pkgname#*-}-${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}