python-fastbencode/PKGBUILD

30 lines
1021 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-fastbencode
pkgver=0.3.1
pkgrel=1
pkgdesc="Implementation of bencode with optional fast C extensions"
arch=('x86_64')
url="https://github.com/breezy-team/fastbencode"
license=('GPL-2.0-or-later')
depends=('glibc' 'python')
makedepends=('python-build' 'python-installer' 'python-cython' 'python-setuptools' 'python-wheel')
source=(https://github.com/breezy-team/fastbencode/archive/v${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(103c93fe84db0c7088de4e2944c70e619d674e8fe55161130aeb1492eec679f9)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m build --wheel --no-isolation
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}