python-flit-core/PKGBUILD

31 lines
940 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-flit-core
pkgver=3.10.1
pkgrel=1
pkgdesc="A PEP 517 build backend for packages using Flit"
arch=('x86_64')
url="https://pypi.org/project/flit-core/"
license=('BSD')
depends=('python')
makedepends=('python-build' 'python-installer')
source=(https://pypi.org/packages/source/f/flit-core/flit_core-${pkgver}.tar.gz)
sha256sums=(66e5b87874a0d6e39691f0e22f09306736b633548670ad3c09ec9db03c5662f7)
build() {
cd flit_core-${pkgver}
python3 -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd flit_core-${pkgver}
python3 bootstrap_install.py --install-root ${pkgdir} dist/*.whl
}