python-gi-docgen/PKGBUILD

44 lines
1.1 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-gi-docgen
pkgver=2024.1
pkgrel=1
pkgdesc="Documentation generator for GObject-based libraries"
arch=('x86_64')
url="https://gnome.pages.gitlab.gnome.org/gi-docgen"
license=('Apache-2.0 OR GPL-3.0-or-later')
depends=(
'python'
'python-jinja2'
'python-magic'
'python-markdown'
'python-markupsafe'
'python-packaging'
'python-pygments'
'python-typogrify'
)
makedepends=(
'python-build'
'python-installer'
'python-setuptools'
'python-wheel'
)
source=(https://github.com/GNOME/gi-docgen/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(c2f49f0bdea0366d04b6ab6f34071f324ef70016bc3650371cc08d3c6f2764da)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m build --wheel --no-isolation
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}