python-hatchling/PKGBUILD

37 lines
1.1 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-hatchling
pkgver=1.25.0
pkgrel=1
pkgdesc="Extensible, standards compliant build backend used by Hatch"
arch=('x86_64')
url="https://github.com/pypa/hatch/tree/master/backend"
license=('MIT')
depends=(
'python'
'python-packaging'
'python-pathspec'
'python-pluggy'
'python-editables'
'python-trove-classifiers'
)
makedepends=('git' 'python-build' 'python-installer')
source=(https://github.com/pypa/hatch/archive/${pkgname#*-}-v${pkgver}/hatch-${pkgname#*-}-v${pkgver}.tar.gz)
sha256sums=(0d8d66b687b8e765d19d2d0560f182457aa78cdbc45fef9430655ccaf1cd34b1)
build() {
cd hatch-${pkgname#*-}-v${pkgver}/backend
python3 -m build --wheel --no-isolation
}
package() {
cd hatch-${pkgname#*-}-v${pkgver}/backend
python3 -m installer --destdir=${pkgdir} dist/*.whl
}