30 lines
942 B
Bash
30 lines
942 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=python-idna
|
|
pkgver=3.10
|
|
pkgrel=1
|
|
pkgdesc="Internationalized Domain Names in Applications (IDNA)"
|
|
arch=('x86_64')
|
|
url="https://github.com/kjd/idna"
|
|
license=('BSD')
|
|
depends=('python')
|
|
makedepends=('python-build' 'python-installer' 'python-flit-core')
|
|
source=(https://files.pythonhosted.org/packages/source/i/${pkgname#*-}/${pkgname#*-}-${pkgver}.tar.gz)
|
|
sha256sums=(12f65c9b470abda6dc35cf8e63cc574b1c52b11df2c86030af0ac09b01b13ea9)
|
|
|
|
build() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m build --wheel --no-isolation
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m installer --destdir=${pkgdir} dist/*.whl
|
|
}
|