30 lines
949 B
Bash
30 lines
949 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=python-installer
|
|
pkgver=0.7.0
|
|
pkgrel=2
|
|
pkgdesc="Low-level library for installing a Python package from a wheel distribution"
|
|
arch=('x86_64')
|
|
url="https://pypi.org/project/installer/"
|
|
license=('MIT')
|
|
depends=('python')
|
|
makedepends=('python-flit-core' 'python-build')
|
|
source=(https://github.com/pypa/installer/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
|
|
sha256sums=(e1589201863a6b6f570ce2f9994febe54a8d9196e0cc54fd331cd7ffd728fb86)
|
|
|
|
build() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m build -wn --skip-dependency-check
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
PYTHONPATH=src python3 -m installer -d ${pkgdir} dist/*.whl
|
|
}
|