30 lines
950 B
Bash
30 lines
950 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=python-merge3
|
|
pkgver=0.0.15
|
|
pkgrel=1
|
|
pkgdesc="Python implementation of 3-way merge"
|
|
arch=('x86_64')
|
|
url="https://github.com/breezy-team/merge3"
|
|
license=('GPL2')
|
|
depends=('python')
|
|
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
|
|
source=(https://github.com/breezy-team/merge3/archive/v${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
|
|
sha256sums=(9ea80b22ad11d06f0a6d769b3a719848b28a9033899591362bad8a458bb9ef14)
|
|
|
|
build() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m build --wheel --no-isolation
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m installer --destdir=${pkgdir} dist/*.whl
|
|
}
|